Installation fails on Ubuntu even if cmake is installed

I have tried to install perceval and quandelibc by using the command "pip install perceval-quandela "(in an environment with python 3.8).
I precise that I have installed cmake using sudo apt install cmake.
I am using Ubuntu 20.04.
The command line interface returns the following :

subprocess.CalledProcessError: Command '['cmake', '--build', '.', '--target', 'quandelibc']' returned non-zero exit status 2.
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
  ERROR: Failed building wheel for quandelibc
  Running clean for quandelibc
Failed to build quandelibc
Installing collected packages: quandelibc, mpmath, sympy, pillow, numpy, kiwisolver, fonttools, cycler, scipy, matplotlib, perceval-quandela
  Running install for quandelibc ... error
  error: subprocess-exited-with-error
  × Running install for quandelibc did not run successfully.
  │ exit code: 1
  ╰─> [114 lines of output]
      /home/hector/Documents/qoptique/venv/lib/python3.8/site-packages/setuptools/ SetuptoolsDeprecationWarning: setuptools.installer is deprecated. Requirements should be satisfied by a PEP 517 installer.
      running install
      /home/hector/Documents/qoptique/venv/lib/python3.8/site-packages/setuptools/command/ SetuptoolsDeprecationWarning: install is deprecated. Use build and pip and other standards-based tools.

How can I fix this issue ?
Thanks for your response.

Hello Hector,

Welcome to Perceval, and thank you for the feedback !
Looks like a dev dependency managed to get into the release… we’ll fix this ASAP.

In the meantime, could you please install “git” ?

sudo apt install git

Please let me know if this doesn’t fix the issue.

I have tried installing git before, as you suggested, but this doesn’t fix the issue.

Maybe upgrade pip with pip install --upgrade pip.
Does pip install quandelibc fail as well? If not, try again pip install perceval-quandela afterwards.

we just released a new version of quandelibc : v0.5.1.
you should be able to install it with

pip install --upgrade quandelibc

and this should fix your installation issue,
let me know if this works !

1 Like