Error in Sampler counts


I’m running some simple tests in the QPU with Sampler. When I read the results, I get more counts than the number of samples I have assigned. Here is the code that I’m using:

rx_test = (pcvl.Circuit(2)
           .add(0, BS.Rx(theta= np.pi ))
           .add(0, BS.Rx(theta= np.pi )))

remote_qpu = pcvl.RemoteProcessor("qpu:ascella", token_qcloud) 
remote_qpu.with_input(pcvl.BasicState([1, 0]))

sampler = Sampler(remote_qpu)

nsample = 10000
remote_job = sampler.sample_count(nsample)#['results']
{'results': BSCount(int, {|1,0>: 106145, |0,1>: 25}),
 'physical_perf': 0.007833302204987094,
 'computed_circuit': <perceval.components.linear_circuit.Circuit at 0x7fe085ea9670>,
 'computed_input': |1,0,0,0,0,0,0,0,0,0,0,0>,
 'final_mode_number': 2}

The sum of counts in results should be 10000, but I get 106170, which is 96170 more counts than my parameter nsample

Is there any error in my code? Or another way of using Sampler?

Thanks for the help!

Hello Victor,

We’re currently improving the way we control our hardware to be accurate to the sample, when asking for a specific count. However, as of today, we acquire slices of 1 second worth of samples and return them all, so if your job requires a lot less than 1s of acquisition, you’ll get a lot more samples than required. Your code is alright, the issue is on us and we’re about to fix it.


Hi Eric,

Thanks for the answer!
When is the issue expected to be solved?

Hi Victor,

I’m not sure as we need to test a lot before releasing. I’d say not before October.

Best wishes,